Discussion:
actualizar youtube-dl de Buster a Bullseye en estable.
Add Reply
Camaleón
2020-06-07 16:10:01 UTC
Responder
Permalink
La version de youtube-dl disponible en Buster, 2019.01.17-1.1, parece
estar corrupta/dañada ya que al intentar utilizarla recibía este
mensaje de error: "youtube says: video not available" trate de
actualizarla via via el comando "youtube-dl -U" pero recibí este
error:"youtube-dl: error: youtube-dl's self-update mechanism is
disabled on Debian. Please update youtube-dl using apt(8). See
https://packages.debian.org/sid/youtube-dl for the latest packaged
version." Al intentar con apt resultó que la version instalada era la
mas reciente por lo que descargué la version disponible en
Bullseye, 2020.05.08-1, en su formato .deb, lo instalé,
afortunadamente sin errores, tampoco fue modificado/actualizado
ningún otro paquete y el archivo sources.list no sufrió
modificación alguna.
¿Qué lista de repositorios tienes configurados?

cat /etc/apt/sources.list
Por lo que me pregunto si es posible que la versión
del paquete youtube-dl de Bullseye sea incluido como una actualización
regular via apt-update && upgrade en Buster? No se si esto sea
posible y/o recomendable o si se aplica a los procedimientos
para incluir nuevos paquetes en estable,
Sí, siempre y cuando tengas el repo adecuado para ello, como
«proposed updates», «stable updates» o «backports».

https://wiki.debian.org/SourcesList
en todo caso, la
version de youtube-dl en Buster no funciona correctamente y
debe ser reparada/actualizada.
(...)

El error que te da parece de Youtube, no de la aplicación. Los paquetes
de la versión estable no se actualizan si no corrigen fallos de
seguirdad, aunque hay excepciones.

Siempre puedes informar del problema a través del BTS:

https://www.debian.org/Bugs/

Saludos,
--
Camaleón
JavierDebian
2020-06-08 18:20:01 UTC
Responder
Permalink
Buen día,
La version de youtube-dl disponible en Buster, 2019.01.17-1.1, parece
estar corrupta/dañada ya que al intentar utilizarla recibía este
mensaje de error: "youtube says: video not available" trate de
actualizarla via via el comando "youtube-dl -U" pero recibí este
error:"youtube-dl: error: youtube-dl's self-update mechanism is
disabled on Debian. Please update youtube-dl using apt(8). See
https://packages.debian.org/sid/youtube-dl for the latest packaged
version." Al intentar con apt resultó que la version instalada era la
mas reciente por lo que descargué la version disponible en
Bullseye, 2020.05.08-1, en su formato .deb, lo instalé,
afortunadamente sin errores, tampoco fue modificado/actualizado
ningún otro paquete y el archivo sources.list no sufrió
modificación alguna. Por lo que me pregunto si es posible que la versión
del paquete youtube-dl de Bullseye sea incluido como una actualización
regular via apt-update && upgrade en Buster? No se si esto sea
posible y/o recomendable o si se aplica a los procedimientos
para incluir nuevos paquetes en estable, en todo caso, la
version de youtube-dl en Buster no funciona correctamente y
debe ser reparada/actualizada.
Version de Debian: 10.4 (Buster/Stable)
paquete: youtube-dl
version: 2019.01.17-1.1
síntoma: No funciona correctamente y al intentar
utilizarla devuelve el siguiente mensaje de error: "youtube says:video
not available"
sugerencia: actualizar youtube-dl a la version disponible en
Bullseye, 2020.05.08-1 la cual funciona sin problema alguno.
NOTA: Ya que esta es mi primera vez usando este servicio
espero haberlo conforme a los lineamientos para el mismo.
Agrega el repositorio

deb https://www.deb-multimedia.org buster main non-free

(Sigue las instrucciones de aquí)

Actualiza youtube-dl con todas las librerías que le dependen.

Se solucionan los problemas de multimedia en todo.

JAP
Germán Avendaño Ramírez
2020-06-09 04:10:01 UTC
Responder
Permalink
Post by JavierDebian
Agrega el repositorio
deb https://www.deb-multimedia.org buster main non-free
(Sigue las instrucciones de aquí)
Actualiza youtube-dl con todas las librerías que le dependen.
Se solucionan los problemas de multimedia en todo.
JAP
Se puede instalar youtube-dl usando las instrucciones de la página del
proyecto. Aquí también se dan instrucciones para usar pip (python)

Instrucciones https://ytdl-org.github.io/youtube-dl/download.html

Atentamente,
--
Germán Avendaño Ramírez
Lic. Mat. U.D., M.Sc. U.N
Channel Herrera
2020-06-19 15:50:01 UTC
Responder
Permalink
Seguramente falta alguna libreria...o dependencia rota instala con aptitude
no se por que tengo la sensación de ser mas fiable que apt

El lun., 8 jun. 2020 10:00 p. m., Germán Avendaño Ramírez <
Post by JavierDebian
Agrega el repositorio
deb https://www.deb-multimedia.org buster main non-free
(Sigue las instrucciones de aquí)
Actualiza youtube-dl con todas las librerías que le dependen.
Se solucionan los problemas de multimedia en todo.
JAP
Se puede instalar youtube-dl usando las instrucciones de la página del
proyecto. Aquí también se dan instrucciones para usar pip (python)
Instrucciones https://ytdl-org.github.io/youtube-dl/download.html
Atentamente,
--
Germán Avendaño Ramírez
Lic. Mat. U.D., M.Sc. U.N
Marcelo P. Llanos C.
2020-07-04 18:30:01 UTC
Responder
Permalink
Buen día,
La version de youtube-dl disponible en Buster, 2019.01.17-1.1, parece
estar corrupta/dañada ya que al intentar utilizarla recibía este
mensaje de error: "youtube says: video not available" trate de
¿Si se reproduce el video de youtube en el navegador? Porque según el
mensaje indica que el video ya no está disponible en youtube.
actualizarla via via el comando "youtube-dl -U" pero recibí este
error:"youtube-dl: error: youtube-dl's self-update mechanism is
disabled on Debian. Please update youtube-dl using apt(8). See
https://packages.debian.org/sid/youtube-dl for the latest packaged
version." Al intentar con apt resultó que la version instalada era la
mas reciente por lo que descargué la version disponible en
Bullseye, 2020.05.08-1, en su formato .deb, lo instalé,
afortunadamente sin errores, tampoco fue modificado/actualizado
ningún otro paquete y el archivo sources.list no sufrió
modificación alguna. Por lo que me pregunto si es posible que la versión
del paquete youtube-dl de Bullseye sea incluido como una actualización
regular via apt-update && upgrade en Buster? No se si esto sea
posible y/o recomendable o si se aplica a los procedimientos
para incluir nuevos paquetes en estable, en todo caso, la
version de youtube-dl en Buster no funciona correctamente y
debe ser reparada/actualizada.
Version de Debian: 10.4 (Buster/Stable)
paquete: youtube-dl
version: 2019.01.17-1.1
síntoma: No funciona correctamente y al intentar
utilizarla devuelve el siguiente mensaje de error: "youtube says:video
not available"
sugerencia: actualizar youtube-dl a la version disponible en
Bullseye, 2020.05.08-1 la cual funciona sin problema alguno.
NOTA: Ya que esta es mi primera vez usando este servicio
espero haberlo conforme a los lineamientos para el mismo.
youtube-dl está en constante desarrollo y tiene constantes cambios para
trabajar de forma correcta, por que constantemente tiene que ser
actualizado en nuestro sistema Debian.

Los repositorios de Debian no siempre tienen la última versión de
youtube-dl, es decir, no actualizan este paquete a cómo va el desarrollo
activo del proyecto youtube-dl, en el proyecto Debian más se centran en la
seguridad y la estabilidad de la versión del paquete (en este caso
youtube-dl) ingresado al desarrollo. Pero eso no es problema para tener la
versión más actualizada de youtube-dl, y hay dos maneras:

1. Mediante python-pip:

# apt install python-pip
# pip install youtube_dl

Para actualizar a la última versión:
# pip install --upgrade youtube_dl


2. Descargarlo desde la página del proyecto https://youtube-dl.org/,
desempaquetarlo, darle permisos de ejecución y ejecutalrlo.
a***@danigil.com
2020-07-04 21:40:01 UTC
Responder
Permalink
si usas el comando git, hice fetch al repositorio de youtube-dl desde github, luego lo actualizo con:

git pull master:master

 desde la carpeta del trabajo del repositorio git,

y de ahí:

python3 youtube_dl/__main__.py OPCIONES

en vez de

youtube-dl OPCIONES

-- Dani
Buen día,
La version de youtube-dl disponible en Buster, 2019.01.17-1.1,  parece
estar corrupta/dañada ya que al intentar utilizarla recibía este
mensaje de error: "youtube says: video not available" trate de
¿Si se reproduce el video de youtube en el navegador? Porque según el mensaje indica que el video ya no está disponible en youtube.
 
actualizarla via via el comando "youtube-dl -U" pero recibí este
error:"youtube-dl: error: youtube-dl's self-update mechanism is
disabled on Debian. Please update youtube-dl using apt(8). See
https://packages.debian.org/sid/youtube-dl>> for the latest packaged
version." Al intentar con apt resultó que la version instalada era la
mas reciente por lo que descargué la version disponible en
Bullseye, 2020.05.08-1, en su formato .deb, lo instalé,
afortunadamente sin errores, tampoco fue modificado/actualizado
ningún otro paquete y el archivo sources.list no sufrió
modificación alguna. Por lo que me pregunto si es posible que la versión
del paquete youtube-dl de Bullseye sea incluido como una actualización
regular via apt-update && upgrade en Buster? No se si esto sea
posible y/o recomendable o si se aplica a los procedimientos
para incluir nuevos paquetes en estable, en todo caso, la
version de youtube-dl en Buster no funciona correctamente y
debe ser reparada/actualizada.
Version de Debian: 10.4 (Buster/Stable)
paquete: youtube-dl
version: 2019.01.17-1.1
síntoma: No funciona correctamente y al intentar
utilizarla devuelve el siguiente mensaje de error: "youtube says:video
not available"
sugerencia: actualizar youtube-dl a la version disponible en
Bullseye, 2020.05.08-1 la cual funciona sin problema alguno.
NOTA: Ya que esta es mi primera vez usando este servicio
espero haberlo conforme a los lineamientos para el mismo.           
youtube-dl está en constante desarrollo y tiene constantes cambios para trabajar de forma correcta, por que constantemente tiene que ser actualizado en nuestro sistema Debian.
# apt install python-pip
# pip install youtube_dl
# pip install --upgrade youtube_dl
2. Descargarlo desde la página del proyecto > https://youtube-dl.org/> , desempaquetarlo, darle permisos de ejecución y ejecutalrlo.
Loading...