Discussion:
sin escritorio
(demasiado antiguo para responder)
Aristobulo Pinzon Gmail
2020-05-22 03:30:01 UTC
Permalink
Buenas... Muchas gracias Camaleon. Haciendo lo que sugieres se abre el escritio bien y con todos los elementos usuales; pero cuando se inicia normalmente vuelve sin escritorio y sin ningún mensaje de error...
Camaleón
2020-05-22 06:00:01 UTC
Permalink
Post by Aristobulo Pinzon Gmail
Buenas... Muchas gracias Camaleon. Haciendo lo que sugieres se abre el escritio bien y con todos los elementos usuales; pero cuando se inicia normalmente vuelve sin escritorio y sin ningún mensaje de error...
Pensaba que al iniciar con «startx» el servidor X te sacaría algún mensaje de
error y no podría cargar el entorno gráfico.

Revisa los registros de inicio de sesión y los de Xorg, que los tendrás
en /var/log/Xorg.0.log y, dependiendo del entorno gráfico que uses
(XFCE, GNOME, KDE...) estará en ~/.xsession-errors o con «journalctl
_UID=1000» (reemplaza 1000 con el UID de tu usuario).

Si se ha actualizado el kernel y utilizabas controladores propietarios (p.
ej., nvidia) verifica que las versiones de ambos sean compatibles.

Saludos,
--
Camaleón
Aristobulo Pinzon Gmail
2020-05-22 21:00:02 UTC
Permalink
Muchas gracias Camaleón. Y no. No encuentro ningún mensaje de error en los logs. Tos parece normal. Cuando cierro la sección y la vuelvo a abrir ya me aparece la imagen de fondo de xfce4; sin envargo no aparecen los enlaces. Bueno... no es tan importante. Me desvaro abriendo la carpeta escritorio y allí están todos. Esperare hasta la próxima actualización. De pronto es una falla transitoria.
Camaleón
2020-05-23 07:30:01 UTC
Permalink
Post by Aristobulo Pinzon Gmail
Muchas gracias Camaleón. Y no. No encuentro ningún mensaje de error en los logs. Tos parece normal. Cuando cierro la sección y la vuelvo a abrir ya me aparece la imagen de fondo de xfce4; sin envargo no aparecen los enlaces. Bueno... no es tan importante. Me desvaro abriendo la carpeta escritorio y allí están todos. Esperare hasta la próxima actualización. De pronto es una falla transitoria.
Entonces me parece que no te he entendido bien.

Por lo que dices, se carga el entorno gráfico (XFCE) pero el escritorio
te aparece incompleto ¿es así? En ese caso, podría ser un problema de
refresco del escritorio, en XFCE es bastante habitual. Prueba a recargarlo
ejecutando la orden «xfdesktop --reload», a ver si notas alguna diferencia.

Si recargar el escritorio funciona, prueba a renombrar (que es mejor que
eliminar) el directorio «~/.cache/sessions» donde se almacenan los datos se la sesión actual de
XFCE para tu usuario, quizá haya algún archivo que esté generando
problemas. Supongo que perderás la configuración actual del escritorio
(iconos, posición...) pero si no funciona lo vuelves a renombrar para
dejarlo como estaba.

Saludos,
--
Camaleón
Fabián Bonetti
2020-05-23 19:00:01 UTC
Permalink
Hola...a mi me paso com debian 10.4 con lxde en sesion por defecto.

En la pantalla de login ponia usuario y clave...y volvía a la pantalla de login.

Para salir del paso use seison lxde en la pantalla de login se puede escoger que sesion elegir.

lo que no se es donde quedan las sesiones guardadas en lxde.


saludos
Post by Camaleón
Post by Aristobulo Pinzon Gmail
Muchas gracias Camaleón. Y no. No encuentro ningún mensaje de error en los logs. Tos parece normal. Cuando cierro la sección y la vuelvo a abrir ya me aparece la imagen de fondo de xfce4; sin envargo no aparecen los enlaces. Bueno... no es tan importante. Me desvaro abriendo la carpeta escritorio y allí están todos. Esperare hasta la próxima actualización. De pronto es una falla transitoria.
Entonces me parece que no te he entendido bien.
Por lo que dices, se carga el entorno gráfico (XFCE) pero el escritorio
te aparece incompleto ¿es así? En ese caso, podría ser un problema de
refresco del escritorio, en XFCE es bastante habitual. Prueba a recargarlo
ejecutando la orden «xfdesktop --reload», a ver si notas alguna diferencia.
Si recargar el escritorio funciona, prueba a renombrar (que es mejor que
eliminar) el directorio «~/.cache/sessions» donde se almacenan los datos se la sesión actual de
XFCE para tu usuario, quizá haya algún archivo que esté generando
problemas. Supongo que perderás la configuración actual del escritorio
(iconos, posición...) pero si no funciona lo vuelves a renombrar para
dejarlo como estaba.
Saludos,
--
Enviado desde mi dispositivo Android con Librem Mail. Por favor, disculpa mi brevedad.
Aristobulo_Pinzon
2020-05-24 23:40:02 UTC
Permalink
Exelente. Muchisimas gracias. camaleón

"En ese caso, podría ser un problema de
refresco del escritorio, en XFCE es bastante habitual. Prueba a recargarlo
ejecutando la orden «xfdesktop --reload», a ver si notas alguna diferencia."
Esa fué la solución!.
Sigan siendo felices en la cuarentena.

Loading...