Discussion:
xdmcp y ssh -X
(demasiado antiguo para responder)
TRUJILLO CARMONA ANTONIO
2020-03-11 11:20:01 UTC
Permalink
Es raro, es la tercera vez que envio este correo y parece que no llega,
esta vez lo intento desde otra cuenta.


Estoy usando Debian 10, desde siempre he usado las conexiones gráficas

remotas para gestionar servidores.

También he utilizado ssh -X ***@mipc para trabajo remoto.

Nada de esto funciona ahora, no se desde cuando ni porque, he intentado
reconfigurar gdm con:


[daemon]
# Esto he probado a ponerlo y quitarlo sin diferencia aparente
# WaylandEnable=false

[security]
DisallowTCP=false

[xdmcp]
Enable=true

[chooser]

[debug]

He probado a instalar el xauth sin resultados.

he probado a usar KDE y lxdt He probado a usar sddm sin resultados.

Desde que no funciona gksu utilizo "ssh -X ***@localhost" para poder
lanzar aplicaciones gráficas como administrador, esto si sigue funcionando.

En las conexiones no locales de ssh se puede ver:

"X11 forwarding request failed on channel 0"

el fichero .Xauthority no siempre se crea, pero eso creo que depende de
si se usa Wayland o no, de todas formas aunque se cree no funciona y en
Internet dicen que wayland es compatible con las comunicaciones X
remotas sin necesidad de xauth que es especifico de xorg.


Si no se usa wayland ssh -X sigue sin funcionar, pero "xhost +" +
"Display=mi-ip:0" si funciona, pero esto es inseguro porque esta
enviando todo el trafico por fuera del tunel ssh, es decir en plano.


¿Alguna idea para que vuelva a funcionar?
Sergio Daniel Gomez
2020-03-11 11:30:01 UTC
Permalink
Solo para confirmarte, hay 4 emails con el mismo asunto y mismo remitente.
Post by TRUJILLO CARMONA ANTONIO
Es raro, es la tercera vez que envio este correo y parece que no llega,
esta vez lo intento desde otra cuenta.
Estoy usando Debian 10, desde siempre he usado las conexiones gráficas
remotas para gestionar servidores.
Nada de esto funciona ahora, no se desde cuando ni porque, he intentado
[daemon]
# Esto he probado a ponerlo y quitarlo sin diferencia aparente
# WaylandEnable=false
[security]
DisallowTCP=false
[xdmcp]
Enable=true
[chooser]
[debug]
He probado a instalar el xauth sin resultados.
he probado a usar KDE y lxdt He probado a usar sddm sin resultados.
lanzar aplicaciones gráficas como administrador, esto si sigue funcionando.
"X11 forwarding request failed on channel 0"
el fichero .Xauthority no siempre se crea, pero eso creo que depende de
si se usa Wayland o no, de todas formas aunque se cree no funciona y en
Internet dicen que wayland es compatible con las comunicaciones X
remotas sin necesidad de xauth que es especifico de xorg.
Si no se usa wayland ssh -X sigue sin funcionar, pero "xhost +" +
"Display=mi-ip:0" si funciona, pero esto es inseguro porque esta
enviando todo el trafico por fuera del tunel ssh, es decir en plano.
¿Alguna idea para que vuelva a funcionar?
Loading...